Bup bip bop… iniciando secuencia 42…
¡Llegaron los robots! Han tomado el control y tradujeron esta página a tu idioma local. Sus corazoncitos de metal solo tienen las mejores intenciones. ¡Quieren ayudar! Dinos si están haciendo un buen trabajo con los botones al final de la página. Ve a la versión en inglés

Cambiar la extensión de archivo controladores o idiomas (Linux)

Su hospedaje de Linux de cuenta permite procesar archivos en diferentes idiomas. Extensiones de archivo determinan el comportamiento de predeterminado de tu cuenta. Por ejemplo, su cuenta procesa los archivos que terminan en .html como HTML estático y predeterminado de la cuenta PHP versión procesa los archivos que terminan en .php .

Con controladores de Apache, puede actualizar su .htaccess archivo para cambiar el comportamiento predeterminado de la cuenta de la extensión de archivo, o puede agregar extensiones de archivo personalizadas.

Consulte la tabla siguiente para el comportamiento predeterminado de los lenguajes dinámicos.

Extensión Controlador Versión
.php x-httpd-php Versión PHP predeterminado
.php5 x-httpd-php5-3 PHP 5.3
.pl, .rb,
.py, .cgi
secuencia de comandos CGI Depende del idioma
.fcgi, .fpy,
.fpl
secuencia de comandos fcgid Depende del idioma


Cambiar el comportamiento predeterminado de extensiones de archivo en su cuenta de hospedaje puede producir resultados inesperados, posiblemente deshabilitar software instalado. Esta característica avanzada está diseñada sólo para usuarios con experiencia.

Algunas extensiones necesitan preparación de secuencias de comandos de idioma específico (por ejemplo, secuencias de comandos para el uso mediante CGI o FastCGI), que queda fuera del alcance de este artículo.

Cambiar las extensiones de archivo predeterminadas

Puede cambiar el comportamiento predeterminado de la cuenta de la extensión de archivo mediante la actualización de la .htaccess el archivo con un controlador.

Por ejemplo, si su versión PHP abre la extensión de archivo .php , y desea cambiarlo a PHP 5.3 , agregue el código siguiente a su cuenta de hospedaje .htaccess archivo:

AddHandler x-httpd-php5-3 .php

Del mismo modo, si desea que FastCGI para procesar todos los archivos con extensión .pl , agregue el código siguiente a su cuenta de hospedaje .htacess archivo:

AddHandler fcgid-script .pl


Creación de extensiones de archivo personalizadas

También puede crear extensiones de archivo personalizadas mediante la actualización de su cuenta de alojamiento .htaccess el archivo con un controlador.

Por ejemplo, si agrega el siguiente código en el .htaccess archivo, PHP 5.3 puede procesar la extensión personalizada .mysite :

Options +ExecCGI
AddHandler x-httpd-php5-3 .mysite

Deshabilitación de FastCGI

Puede deshabilitar FastCGI usando este método, incluyendo lo siguiente en el .htaccess archivo:

Options +ExecCGI
addhandler x-httpd-php5-cgi .php

No se puede deshabilitar FastCGI con nuestras cuentas de hospedaje compartido del panel de control (más información) o con versiones PHP versión 5.3 o posteriores las cuentas Web/clásico (más información).

Haga clic aquí para obtener más información acerca de controladores de Apache.


¿Este artículo fue útil?
Gracias por tus comentarios
¡Nos complace haber ayudado! ¿Hay algo más que podamos hacer por ti?
Lo sentimos. ¿Cómo podríamos ser de más utilidad?